Requirements for the Splunk Plug-in for Eclipse

Here's what you need to get going with the Splunk® Plug-in for Eclipse.

Eclipse

The Splunk Plug-in for Eclipse requires Eclipse 4.2 or later running on any of its supported operating systems.

Splunk Enterprise

If you haven't already installed Splunk Enterprise, download it here. For more about installing and running Splunk Enterprise and system requirements, see the Splunk Enterprise Installation Manual.

Splunk Plug-in for Eclipse

There is no separate download required for the Splunk Plug-in for Eclipse. Simply follow the instructions in Installation. Installing the Splunk Plug-in for Eclipse also installs the Splunk SDK for Java.