Requirements for Splunk logging for .NET

Here's what you need to get going with Splunk logging for .NET:

  • .NET Framework 4.5 or later: Splunk logging for .NET requires at least .NET 4.5.
  • Splunk Enterprise: If you haven't already installed Splunk Enterprise, download it at For more information about installing and running Splunk Enterprise and system requirements, see the Splunk Installation Manual.

To run the unit tests, you'll need the following:

To build the logging libraries, you'll need the following: