Requirements for the Splunk Extension for Visual Studio

Here's what you need to get going with the Splunk® extension for Visual Studio.

Visual Studio

The Splunk extension for Visual Studio requires Visual Studio 2012 or later:

  • Visual Studio 2012: You can run any edition except for Express, which does not have the ability to install extensions.
  • Visual Studio 2013: You can run any edition except for Community and Express.
  • Visual Studio 2015: You can run Visual Studio 2015 Enterprise, Community, or Professional.

Splunk Enterprise

If you haven't already installed Splunk Enterprise, download it here. For more about installing and running Splunk Enterprise and system requirements, see the Splunk Enterprise Installation Manual.

Splunk extension for Visual Studio

You install the Splunk extension for Visual Studio directly within Visual Studio; there is no separate download. Installing the Splunk extension for Visual Studio also installs the Splunk SDK for C#.

For instructions on installing the Splunk extension for Visual Studio, see Install.