Troubleshooting the Splunk SDK for Ruby

The Splunk SDK for Ruby is deprecated. For more information, see Deprecation notice.

This topic describes how to troubleshoot problems when coding with the Splunk® SDK for Ruby. It contains the following sections:

If you still have questions after reading this topic, see the Questions? sidebar on the right side of this page for additional help.

 

Can't use the SDK with an app written in Ruby 2.x

The Splunk SDK for Ruby requires Ruby 1.9.2 or a later release in the 1.9 series. At this time, Ruby 2 is not supported.

 

Can't run the examples or unit tests

You must update your installations of both the Rake build tool and the Test::Unit unit test framework from RubyGems before running any of the Splunk SDK for Ruby's examples or unit tests. For more information, see Examples and unit tests.

 

Problems using the Splunk SDK for Ruby alongside Ruby on Rails

The Splunk SDK for Ruby is fairly self contained and shouldn't touch anything in Ruby on Rails. Ruby on Rails, however, alters the behavior of many components of the system. Try the same calls to the Splunk SDK for Ruby in the absence of Ruby on Rails. If they succeed, then Ruby on Rails is probably the culprit.