Requirements for Splunk SDK for Ruby

The Splunk SDK for Ruby is deprecated. For more information, see Deprecation notice.

Here's what you need to get going with the Splunk SDK for Ruby:

Splunk Enterprise

If you haven't already installed Splunk Enterprise, download it here. For more information about installing and running Splunk Enterprise and system requirements, see the Splunk Enterprise Installation Manual.

Ruby

The Splunk SDK for Ruby has been tested with Ruby 1.9.2 and Ruby 1.9.3. Splunk recommends using one of those versions for best results.

Note: Ruby 2 is not supported.

Splunk SDK for Ruby

Download the Splunk SDK for Ruby as a ZIP and extract the files.

If you want to verify your download, download an MD5 or download a SHA-512.

To contribute to the Splunk SDK for Ruby, see the Splunk SDK for Ruby on GitHub.