Requirements for Splunk SDK for Python

Here's what you need to get going with the Splunk SDK for Python:

Splunk Enterprise

If you haven't already installed Splunk Enterprise, download it here. For more information about installing and running Splunk Enterprise and system requirements, see the Splunk Enterprise Installation Manual.

Python

The Splunk SDK for Python requires Python 2.6 or later. At this time, Python 3.x is not supported.

Splunk SDK for Python

Download the Splunk SDK for Python as a ZIP and extract the files.

If you want to verify your download, download an MD5 or download a SHA-512.

To contribute to the Splunk SDK for Python, see the Splunk SDK for Python on GitHub.