Requirements for the Splunk SDK for PHP

The Splunk SDK for PHP is deprecated. For more information, see Deprecation notice.

Here's what you need to get going with the Splunk SDK for PHP.

Splunk Enterprise

If you haven't already installed Splunk Enterprise, download it here. For more information about installing and running Splunk Enterprise and system requirements, see the Splunk Enterprise Installation Manual.

PHP

The Splunk SDK for PHP has been tested with PHP 5.2.x, 5.3.x, and 5.4.x, with the SimpleXML extension. For best results, Splunk recommends PHP 5.3.7 or higher, or PHP 5.4.x.

Note: There is a known issue with PHP versions 5.2.11 through 5.3.6, which interferes with HTTPS communication, especially with a Splunk server on a localhost. If you see the error message "SSL: Connection reset by peer," try running your PHP script on a different server than the Splunk server, although this does not always resolve the problem.

OpenSSL support for PHP is required to access Splunk Enterprise URLs over https.

Splunk SDK for PHP

Download the Splunk SDK for PHP as a ZIP and extract the files.

If you want to verify your download, download an MD5 or download a SHA-512.