Get Splunk Enterprise

You need Splunk® Enterprise 4.2 or later to use the Splunk SDK for JavaScript. If you haven't already, download Splunk Enterprise: http://www.splunk.com/download.

From here on out, we're assuming you know a little about using Splunk Enterprise already, have some data indexed, and maybe saved a search or two. But if you're not there yet and need some more Splunk Enterprise education, we have you covered:

  • If you want a deeper description of Splunk Enterprise's features, see the Splunk Enterprise documentation.
  • Try the Tutorial in the Splunk Enterprise documentation for a step-by-step walkthrough of using Splunk Enterprise with some sample data.
  • The Splunk SDKs are built as a layer over the Splunk Enterprise REST API. While you don't need to know the REST API to use this SDK, you might find it useful to read the REST API Overview or browse the Splunk Enterprise REST API Reference.